ошибка: stk500_getsync(): not in sync: resp=0x00 - ФОРУМ ДВ Робот dvrobot.ru
Четверг, 24.05.2018, 23:25
Главная Мой профиль Регистрация Выход
  • НАШ МАГАЗИН
  • Вы вошли как Гость | Группа "Гости"Приветствую Вас, Гость
    [ Новые сообщения · Участники · Правила форума · Поиск · RSS ]
    • Страница 1 из 1
    • 1
    Модератор форума: Serg, GRACH  
    ФОРУМ ДВ Робот dvrobot.ru » DV ROBOT » Arduino - вопросы и ответы. » ошибка: stk500_getsync(): not in sync: resp=0x00 (Как лечить?)
    ошибка: stk500_getsync(): not in sync: resp=0x00
    fakirr999Дата: Воскресенье, 02.06.2013, 00:14 | Сообщение # 1
    3.5 Вольт
    Группа: Пользователи
    Сообщений: 10
    Репутация: 0
    Статус: Offline
    Все было хорошо, а тут решил попробовать новый скетч и при заливке выдало ошибку: avrdude: stk500_getsync(): not in sync: resp=0x00. Как лечить? Смена ПК не помогла, TX - RX замыкал - в мониторе ответа нет, с внешним питанием та же петрушка
     
    SergДата: Воскресенье, 02.06.2013, 01:58 | Сообщение # 2
    Ампер
    Группа: Модераторы
    Сообщений: 510
    Репутация: 28
    Статус: Offline
    Цитата (fakirr999)
    TX - RX замыкал - в мониторе ответа нет

    А при подключении появляется СОМ-порт в диспетчере устройств?
     
    fakirr999Дата: Воскресенье, 02.06.2013, 02:11 | Сообщение # 3
    3.5 Вольт
    Группа: Пользователи
    Сообщений: 10
    Репутация: 0
    Статус: Offline
    да, загорается питание и LED 13
     
    SergДата: Воскресенье, 02.06.2013, 02:21 | Сообщение # 4
    Ампер
    Группа: Модераторы
    Сообщений: 510
    Репутация: 28
    Статус: Offline
    извлеки мк, затем перемычку на порты RX-TX, открой терминал и отправь в порт пару букв.
     
    DuZeRДата: Воскресенье, 02.06.2013, 13:23 | Сообщение # 5
    5 Вольт
    Группа: Пользователи
    Сообщений: 42
    Репутация: 2
    Статус: Offline
    ардуино или собственная сборка ?

    Возможности машины зависят от фантазии человека...
     
    fakirr999Дата: Воскресенье, 02.06.2013, 18:04 | Сообщение # 6
    3.5 Вольт
    Группа: Пользователи
    Сообщений: 10
    Репутация: 0
    Статус: Offline
    http://dvrobot.ru/?show=shop&item_id=495 вот эта, в ней МК выпаивать надо

    Добавлено (02.06.2013, 18:04)
    ---------------------------------------------
    смене портов, скорости и кабеля не помогли, сам виноват - повелся на дешевизну. Буду покупать в другом магазе

     
    SergДата: Воскресенье, 02.06.2013, 19:46 | Сообщение # 7
    Ампер
    Группа: Модераторы
    Сообщений: 510
    Репутация: 28
    Статус: Offline
    Не стоит делать столь поспешные выводы.
    СОМ-порт появляется в диспетчере устройств при подключении платы?
     
    Mef78Дата: Четверг, 02.01.2014, 08:00 | Сообщение # 8
    1.5 Вольт
    Группа: Пользователи
    Сообщений: 9
    Репутация: 0
    Статус: Offline
    У меня подобная проблема.
    Плата uno r3 на atmega8a-pu, китай
    http://www.dvrobot.ru/shop/i634.Arduino_UNO_R3_-_Kitay_8.htm
    Купил в вашем магазине. Софт со странички о плате. Выбран optiboot8. Сначала работала, blink проливался. При очередной попытке загрузить скетч выдала ошибку.
    System wide configuration file is "C:\Soft\arduino-1.0.5-windows\arduino-1.0.5\hardware/tools/avr/etc/avrdude.conf"
    Using Port                    : \\.\COM6
    Using Programmer              : arduino
    Overriding Baud Rate          : 115200
    avrdude: Send: 0 [30]   [20]
    avrdude: Send: 0 [30]   [20]
    avrdude: Send: 0 [30]   [20]
    avrdude: Recv:
    avrdude: stk500_getsync(): not in sync: resp=0x00
    avrdude done.  Thank you.

    При замыкании rx-tx (0-1)эхо выводит.
    При включении горит светодиод ON, i/o 13 не горит и не мигает, мигать даже не пытается.
    Что делать ? уже весь интернет перерыл, простого способа оживить платку не нашел. Печально... Что делать ????


    Сообщение отредактировал Mef78 - Четверг, 02.01.2014, 08:02
     
    SergДата: Четверг, 02.01.2014, 13:31 | Сообщение # 9
    Ампер
    Группа: Модераторы
    Сообщений: 510
    Репутация: 28
    Статус: Offline
    Цитата ;1582
    Выбран optiboot8

    Это где такое выбирается?
     
    Mef78Дата: Четверг, 02.01.2014, 15:01 | Сообщение # 10
    1.5 Вольт
    Группа: Пользователи
    Сообщений: 9
    Репутация: 0
    Статус: Offline
    В софтине что рекомендовалась к скачке... со странички на ссылке
    http://www.dvrobot.ru/shop/i634.Arduino_UNO_R3_-_Kitay_8.htm
    самое интересное что только так работало, а если выбирать arduino ng atmega8 - не работало. И не работает





    Прикрепления: 3142392.jpg(117.8 Kb) · 6260150.jpg(47.6 Kb) · 5464341.jpg(48.0 Kb)


    Сообщение отредактировал Mef78 - Четверг, 02.01.2014, 15:05
     
    SergДата: Четверг, 02.01.2014, 16:07 | Сообщение # 11
    Ампер
    Группа: Модераторы
    Сообщений: 510
    Репутация: 28
    Статус: Offline
    Нужно заново записать bootloader в микроконтроллер. Есть еще одна Arduino или программатор?
     
    Mef78Дата: Четверг, 02.01.2014, 16:33 | Сообщение # 12
    1.5 Вольт
    Группа: Пользователи
    Сообщений: 9
    Репутация: 0
    Статус: Offline
    Есть, второй такой же Arduino.
    Если можно, инструкцию поподробнее.
    Как я понял читая интернет, проблема достаточно частая.
     
    SergДата: Четверг, 02.01.2014, 17:04 | Сообщение # 13
    Ампер
    Группа: Модераторы
    Сообщений: 510
    Репутация: 28
    Статус: Offline
    http://arduino.cc/en/Tutorial/ArduinoISP
    Вот тут с картинками. В рабочую плату записывается скетч ArduinoISP. Затем выбирается тип программатора, тип той неисправной платы и нажимается Записать загрузчик


    Ни разу таким способом не пользовался, но должно работать
    Прикрепления: 4530364.jpg(54.1 Kb)
     
    SergДата: Четверг, 02.01.2014, 17:05 | Сообщение # 14
    Ампер
    Группа: Модераторы
    Сообщений: 510
    Репутация: 28
    Статус: Offline
    Можно погуглить по ключевым словам ArduinoISP
     
    Mef78Дата: Пятница, 03.01.2014, 00:02 | Сообщение # 15
    1.5 Вольт
    Группа: Пользователи
    Сообщений: 9
    Репутация: 0
    Статус: Offline
    Попробовал, все как по инструкции.
    На вторую плату отлично залился скетч, соединил проводами как по схеме, и... никак. Не шьется... выдает ошибку.
     
    SergДата: Пятница, 03.01.2014, 00:47 | Сообщение # 16
    Ампер
    Группа: Модераторы
    Сообщений: 510
    Репутация: 28
    Статус: Offline
    Значит неисправен микроконтроллер.
     
    GRACHДата: Суббота, 04.01.2014, 15:14 | Сообщение # 17
    dvrobot.ru
    Группа: Администраторы
    Сообщений: 111
    Репутация: 16181
    Статус: Offline
    fakirr999Mef78, пишите на dvrobot@yandex.ru вам заменят платы или вернут деньги.
     
    Mef78Дата: Суббота, 04.01.2014, 22:00 | Сообщение # 18
    1.5 Вольт
    Группа: Пользователи
    Сообщений: 9
    Репутация: 0
    Статус: Offline
    Сегодня перебросил микроконтроллеры местами между "рабочей" и "нерабочей" платой. Якобы "неисправный" микроконтроллер отлично завелся, а микроконтроллер с исправной платы - нет. С учетом того что на плате конвертор usb-rs232 рабочий, и при замыкании ног rx-tx отвечает в терминале, вероятнее всего проблема в кварце (а больше ничего и не остается). Из-за него и не стартует микроконтроллер.

    Цитата GRACH ()
    fakirr999, Mef78, пишите на dvrobot@yandex.ru вам заменят платы или вернут деньги.
    Спасибо за предложение.
    По замене плат: почтовые расходы сравнимы с ценой платы, возврат денег не нужен. Так что куплю и перепаяю кварц сам.
     
    GRACHДата: Воскресенье, 05.01.2014, 15:29 | Сообщение # 19
    dvrobot.ru
    Группа: Администраторы
    Сообщений: 111
    Репутация: 16181
    Статус: Offline
    Mef78, ждем результатов.
     
    Mef78Дата: Четверг, 20.03.2014, 19:48 | Сообщение # 20
    1.5 Вольт
    Группа: Пользователи
    Сообщений: 9
    Репутация: 0
    Статус: Offline
    после праздников буду пробовать.
    еще из идей - пробитый транзистор что стоит в цепи reset.
    дома нет ни мультиметра, ни паяльника.

    Добавлено (10.01.2014, 21:20)
    ---------------------------------------------
    Проблему решил, возможно не самым правильным способом, но, оно заработало.
    Эту платку ардуино я брал у отца взаймы. Мне пришла посылка с точно такой же платкой на atmega8u и вторая точно такая же, но на atmega328u. Платку на 8й атмеге вернул отцу не распаковывая.
    328 камень перебросил местами с 8 и о чудо, обе платы заработали. Все вернул как было - работает только плата с 328 камнем. Глюк...
    В общем снова поменял процессоры местами и забил на это дело.
    Главное что сейчас обе платы работают.

    Добавлено (31.01.2014, 20:17)
    ---------------------------------------------
    И еще вдогонку. Пришел ко мне USBasp
    Так вот, на исправной плате все отлично прошивает, что загрузчик, что скомпилированную программу.
    На "глючной" плате шить не хочет и вываливается по ошибке. Поскольку при програмировании через IСSP задействован только микроконтроллер и кварц, все-таки склоняюсь к глючности именно кварцевого резонатора на плате. Надеюсь кому-нибудь это поможет.

    Добавлено (20.03.2014, 19:48)
    ---------------------------------------------
    Поменял кварц - все стало отлично работать. Дело было в глючном кварце.

    Сообщение отредактировал Mef78 - Пятница, 31.01.2014, 20:17
     
    SergДата: Четверг, 20.03.2014, 20:11 | Сообщение # 21
    Ампер
    Группа: Модераторы
    Сообщений: 510
    Репутация: 28
    Статус: Offline
    иногда бывает полезно заземлить корпус кварца
     
    ФОРУМ ДВ Робот dvrobot.ru » DV ROBOT » Arduino - вопросы и ответы. » ошибка: stk500_getsync(): not in sync: resp=0x00 (Как лечить?)
    • Страница 1 из 1
    • 1
    Поиск:

    ДВ Робот - Чат