проблема с сервой TowerPro MG995 - ФОРУМ ДВ Робот dvrobot.ru
Пятница, 16.11.2018, 04:47
Главная Мой профиль Регистрация Выход
  • НАШ МАГАЗИН
  • Вы вошли как Гость | Группа "Гости"Приветствую Вас, Гость
    [ Новые сообщения · Участники · Правила форума · Поиск · RSS ]
    • Страница 1 из 1
    • 1
    Модератор форума: Serg, GRACH  
    ФОРУМ ДВ Робот dvrobot.ru » DV ROBOT » Arduino - вопросы и ответы. » проблема с сервой TowerPro MG995
    проблема с сервой TowerPro MG995
    HitRunДата: Среда, 19.11.2014, 17:58 | Сообщение # 1
    1.5 Вольт
    Группа: Пользователи
    Сообщений: 4
    Репутация: 0
    Статус: Offline
    Когда подключаешь серву к ардуине и пытаешься провернуть на определенный угол, она поворачивается и сразу же возвращается в начальное положение, а иногда она просто загоняет себя в крайний угол( по идее 180) и пытается крутится дальше, но у нее это, естественно, не получается, так же перестает реагировать на какие либо другие углы, пока не отключишь питание и в ручную не повернешь ее куда-нибудь. На многих форумах говорят, что это проблема с питание. Попробовал разные источники, результат один и тот же. Подскажите как заставить их адекватно работать?
     
    SergДата: Среда, 19.11.2014, 19:10 | Сообщение # 2
    Ампер
    Группа: Модераторы
    Сообщений: 510
    Репутация: 28
    Статус: Offline
    Вполне возможно- неисправность переменного резистора внутри двигателя.
     
    HitRunДата: Среда, 19.11.2014, 19:26 | Сообщение # 3
    1.5 Вольт
    Группа: Пользователи
    Сообщений: 4
    Репутация: 0
    Статус: Offline
    2 сервы реагируют абсолютно одинаково. разве может такое быть, что мне дичайше повезло и 2 сломанные?
     
    SergДата: Среда, 19.11.2014, 19:46 | Сообщение # 4
    Ампер
    Группа: Модераторы
    Сообщений: 510
    Репутация: 28
    Статус: Offline
    Конечно нет. попробуйте другой код, другой вывод Ардуины для управления мотора, раздельные источники питания для мотора и Ардуины.
     
    HitRunДата: Четверг, 20.11.2014, 02:11 | Сообщение # 5
    1.5 Вольт
    Группа: Пользователи
    Сообщений: 4
    Репутация: 0
    Статус: Offline
    было бы хорошо сказать что у меня ардуина mega 2560, пробовал подключать к выходам 7-13,44 результат один и тот же. на разных библиотеках суть одна. разный код дал один результат... питал их отдельно через юсб, через адаптер питания и через крону. результата нету.
     
    SergДата: Четверг, 20.11.2014, 02:43 | Сообщение # 6
    Ампер
    Группа: Модераторы
    Сообщений: 510
    Репутация: 28
    Статус: Offline
    Если вы с Хабаровска.принесите двигатель, разберемся.
     
    HitRunДата: Четверг, 20.11.2014, 19:38 | Сообщение # 7
    1.5 Вольт
    Группа: Пользователи
    Сообщений: 4
    Репутация: 0
    Статус: Offline
    подключил его к 2А 7.2В стал работать вроде правильно. но местами дергается и идет рывками не большими.
     
    Sla4eRДата: Четверг, 20.11.2014, 21:12 | Сообщение # 8
    12 Вольт
    Группа: Пользователи
    Сообщений: 108
    Репутация: 2
    Статус: Offline
    То что рывками это серва аналоговая и плохо смазан редуктор!
     
    ФОРУМ ДВ Робот dvrobot.ru » DV ROBOT » Arduino - вопросы и ответы. » проблема с сервой TowerPro MG995
    • Страница 1 из 1
    • 1
    Поиск:

    ДВ Робот - Чат